• أعضاء وزوار معهد زين العربية، نود أن نعلمكم أن المعهد سيشهد في الفترة القادمة الكثير من التغيرات سواءا على المستوى الاداري او مستوى الاقسام، لذا نرجو منكم التعاون، وأي ملاحظات او استفسارات يرجى التواصل معنا عبر قسم الشكاوي و الإقتراحات و الطلبات ونشكركم على حسن تفهمكم وتعاونكم ،مع خالص الشكر والتقدير والاحترام من إدارة زين العربية.

[ نسخة جديدة ] صدور النسخة 2.1.9 و 2.0.13 ( ترقيع أمني )

الحالة
مغلق و غير مفتوح للمزيد من الردود.

أبو غَيْث

:: الإدارة العامة ::
طاقم الإدارة
23 يناير 2019
5,241
40
3,265
113
زين العربية
xenarabia.com
قامت شركة XenForo بإطلاق إصدار جديد من سكربت XenForo.

ويحمل هذا الإصدار ترقيع امني متعلق بخدمة الباي بال الخاصة بالشركة و لمن قامو بالشراء من خلال الباي بال.

لذا وجب الترقية بأسرع وقت سواءا للعملاء الذين يستخدمون النسخة 2.0 أو النسخة 2.1.

أو يمكن إستخدام الملفين المرفقين و استبدال الملف الخاص بالنسخة المناسبة الموجودة بالمسار التالي : src/XF/Payment/PayPal.php

فضلا إذا كنت تستخدم النسخة 2.1 فقم باستخدام الملف xf-patch-219.zip اما اذا كنت تستخدم النسخة 2.0 فاستخدم الملف xf-patch-2013.zip .

تذكير بمتطلبات التشغيل لتعمل النسخ بكفاءة فهي :

  • PHP 5.6 أو أحدث (PHP 7.3 يوصى به)
  • MySQL 5.5 أو أحدث (أيضا متوافق مع MariaDB/Percona إلخ.)
  • جميع الإضافات الرسمية تتطلب XenForo 2.1.
  • إضافة Enhanced Search يتطلب آخر إصدار Elasticsearch 2.0.
جميع عملاء XenForo يمكنهم تحميل النسخ من منطقة العميل : Customer Login | XenForo

تنبيه مهم :
  • في حالة الترقية إلى النسخة 2.1.9 فيجب أيضا ترقية الإضافات الرسمية التي تستخدمها تجنبا لأي مشاكل أو تعارض مع النسخة
  • في حالة الترقية من الجيل الأول فيجب أن تدرك أن إضافات و إستايلات الجيل الأول لا تتوافق كليا مع الجيل الثاني
  • بخصوص بعض إضافات و إستايلات الجيل الثاني النسخة XF2.0.x فقد تكون أيضا غير متوافقة مع النسخة XF2.1.x لذا وجب التأكد من توافقها مع النسخة الجديدة وتجربتها قبل الترقية.
المصدر : XenForo 2.1.9 and 2.0.13 Released (Security Fix)
 

المرفقات

التعديل الأخير:
إصلاح لمن يستخدمون إصدار أقل من XenForo 2.1.5

لقد تم لفت انتباهنا إلى أن العملاء الذين يستخدمون إصدارات XenForo 2.1 ما قبل XenForo 2.1.5 قد يواجهون أخطاء في الخادم بسبب الإصدارات القديمة من XenForo 2.1 التي لا تحتوي على طريقة تستخدمها الإصدارات الأحدث.

لذلك إذا كنت تستخدم XenForo 2.1.0 - 2.1.4، فيجب عليك استخدام xf-patch-214.zip المرفق بدلاً من التصحيح xf-patch-219.zip المذكور في المشاركة الأولى.
 

المرفقات

الحالة
مغلق و غير مفتوح للمزيد من الردود.

المواضيع المُشابهة

إحصائيات المنتدى

المواضيع
1,444
المشاركات
16,588
الأعضاء
1,021
آخر عضو مسجل
wallas
أعلى